The NEW 2016 Annual Security is now available.

ALL hmis users* must take the training by 12/31/16.

*New users in 2016 are exempt.

IMPORTANT NOTES

  • To access the training, click here.
  • For best results, please use Firefox or Internet Explorer.
  • Make sure you have speakers or headphones to view the training.
  • You must complete the survey at the end of the training to receive credit.

Troubleshooting tips

  • Click the refresh button on your browser
  • Audio issues in Chrome?  Try switching to Firefox or Internet Explorer
  • Loading issues in Internet Explorer?  Try switching to Firefox
  • Persistent loading issues?  Check your internet connection
  • If none of the above have worked, email wisp@icalliances.org with the name and version of your browser and describe the issue in detail.